В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

PYTHON 3
Напишите программу, которая будет вложенных циклов выводить на экран следующею фигуру. Также длина самой длинной строчки со звёздочками должна равняться N.
Вводные данные: на первой строке число N.
Исходные данные: фигура со звездочками, где длинная строка содержит N звездочек.
Примечание: команда print() может быть использована с параметром "end=", что означает по окончанию вывода данного объекта продолжить со следующим значением. Написав print("*", end = " ") можно сделать чтобы звёздочки выводились через пробел, а затем написав print(end="\n"), чтобы осуществить перенос.

Ответ:
lgolar
lgolar
11.10.2020 11:31

n = int(input())

for i in range(n):

   for j in range(i):

       print("*",end = " ")

   print('*')

for i in range(n-2,-1,-1):

   for j in range(i):

       print("*",end = " ")

   print('*')

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?