В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alsumamadaliev
alsumamadaliev
10.07.2022 07:36 •  Информатика

Сумма максимальных

Напишите программу, которая будет вычислять сумму максимальных значения из каждого списка чисел.

Вводные данные: в первой строке число N, количество списков с числами. Затем N строк, на каждой строке числа написанные через пробел.

Выходные данные: сумма максимальных значений каждого списка.

Ввод:
4
2 20 1 7 8
9 19
10 8 8 13 2 17
6 9 9

Вывод должен быть таким:
65

Ответ:
tate6
tate6
11.10.2020 11:25

lists = [list(map(int, input().split())) for i in range(int(input()))]

max_summ = 0

for lst in lists:

   max_summ += max(lst)

print(max_summ)


Сумма максимальных Напишите программу, которая будет вычислять сумму максимальных значения из каждог
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?