В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
furi2
furi2
14.02.2020 04:59 •  Информатика

Написать программу на языке Pascal для нахождения НОД ( наибольшего общего делителя для чисел 4, 8 , 16 , 20 , 24.

Ответ:
Умник6791
Умник6791
20.02.2020 01:03

Держи вводи 2 числа и находи нод

Объяснение:

var k, l, n: integer;   function nod (var a,b: integer): integer; var c: integer; begin repeat if a > b then a := a mod b else b := b mod a; until (a = 0) or (b = 0);   nod := a + b; end;   begin   writeln ('Введите два числа: '); readln (k, l);   n := nod (k, l);   writeln ('НОД = ', n);   readln end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?