В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ммаа2
ммаа2
04.02.2023 21:35 •  Информатика

Написать программу в паскале : символы, стоящие на четных местах заменить на *. пользоваться можно только: pos,insert,delete,length,copy

Ответ:
deniskupriyano
deniskupriyano
24.05.2020 04:16

чесно говоря без них куда легче

 

var s:string;

i:integer;

Begin

  read(s);

  for i:= 1 to length(s) do

    if i mod 2 = 0 then s[i]:='*';

  writeln(s);

End.

 

с ними только больше кода

 

var s:string;

i:integer;

Begin

  read(s);

  for i:= 1 to length(s) do

    if i mod 2 = 0 then begin

      Delete(s,i,1);

      Insert('*',s,i);

    end;

  writeln(s);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?