В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
VeshkinRuslan
VeshkinRuslan
21.05.2020 14:55 •  Информатика

Напишите программу:
программа генерирует случайное n (от -100 до 100). в цикле n раз генерируется другое случайное число x. подсчитать и вывести количество х кратных трём, отдельно - список х меньших 0, отдельно сумму х больших 50 подсказка: для каждого искомого значения нужна отдельная переменная

Ответ:
MashaSay
MashaSay
23.08.2020 13:41

C# 8.0:

using System;

using System.Collections.Generic;

...

Random rnd = new Random();

long SumOfGreater50 = 0, Mult3 = 0, Num, n = 10;

var Negative = new List<long>();

for (; n > 0; n--)

{

   Num = rnd.Next(-100, 101);

   if (Num % 3 == 0)

       Mult3++;

   if (Num > 50)

       SumOfGreater50 += Num;

   if (Num < 0)

       Negative.Add(Num);

}

Console.WriteLine($"Num of multipliers of 3: {Mult3}");

Console.WriteLine("Negative nums:");

foreach (long i in Negative) Console.Write($"{i} ");

Console.WriteLine($"\nSum of nums greater than 50:{SumOfGreater50}");

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?