В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
liona676
liona676
03.12.2022 07:43 •  Информатика

Напишите программу информатика (75 )!
определить, верно ли, что при делении натурального числа a на натуральное число b получится остаток, равный числу c.

Ответ:
andreykotov6
andreykotov6
11.10.2020 04:07

var

a,b,c,ostatok:integer;

cr:real;

begin

a:=5;

b:=3;

//Если использовать не целочисленного деление,

//то будет 1.666666666...

cr:=a / b;

 writeln ('При нецелочисленном делении c=',cr);

//Если использовать целочисленного деление,

//то будет 1

c:=a div b;

writeln ('При целочисленном делении c=',c);

//Проверим остаток при целочисленном делении арифметический

ostatok := a-c*b;

writeln ('При делении ',a,' на ',b,' остаток = ',ostatok);

//Проверим остаток при целочисленном делении с операции mod

ostatok := a mod b;

writeln ('При делении ',a,' на ',b,' остаток = ',ostatok);

end.

Объяснение:


Напишите программу информатика (75 )! определить, верно ли, что при делении натурального числа a на
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?