В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vasilek2006
Vasilek2006
03.08.2021 14:03 •  Информатика

Составить программу решения на паскале :
вариант 1 (#1-5) щ

Ответ:
Natasha1146
Natasha1146
11.10.2020 03:56

var a:integer;

m:string;

begin  

repeat

repeat  

writeln('длина и площадь(1), сумма и произведение 5 чисел(2),найти площадь 2-х кругом с радиусом r1 и r2 и вывести большую s(3),2 числа(4),точка(5).');

readln(a);

until a<=5;

case a of

1:begin  

var r,c,s:real;

 writeln('введите R');

 readln(r);

 c:=2*3.14*r;//длина окружности

 s:=3.14*sqr(r);//площадь круга

  writeln('площадь=<',c,'>');

 writeln('S=<',s,'>');

 end;

2:begin

var z1,z2,z3,z4,z5,summ1,summ2:real;

writeln('введите 5 чисел через <enter>');

readln(z1,z2,z3,z4,z5);

summ1:=z1+z2+z3+z4+z5;

summ2:=z1*Z2*Z3*z4*z5;

writeln('сумма=<',summ1,'>');

writeln('произведение=<',summ2,'>');

end;

3:begin

var s,r:real;

writeln('введите R');

readln(r);

s:=3.14*sqr(r);

writeln('S=<',s,'>');

end;

4:begin

var i,u:real;

repeat

writeln('Введите 2 числа через <enter>');

readln(i);

readln(u);

 if (i>u) then

 begin

 i:=i/3;

 u:=u*3;

 end

 else if (u>i)then

 begin

 u:=u/3;

 i:=i*3;

 end

 else until u<>i;

 writeln(i);

 writeln(u);

end;

5:begin

var p,l:real;

writeln('введите а,b через <enter>');

readln(p,l);

 p:=3*p+4;

 if (p=l) then writeln('принадлежат')

 else writeln('не пренадлежат');

end;

end;

writeln('выключит y/n');

readln(m);

until m='y';

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?