В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Znanija027
Znanija027
30.07.2021 02:27 •  Информатика

Написать программу в паскале, которая будет иметь массив содержавший в себе фио человека и дату рождения, полную. при вводе месяца в строку, программа будет выдавать список людей родившихся в этом месяце.

Ответ:
tatarelinagoodoybbdc
tatarelinagoodoybbdc
11.08.2020 23:15

type Man = record

        name: String;

        surname: String;

        date: record

            day: Integer;

            month: Integer;

            year: Integer;

        end;

    end;

 

var people: Array [1..100] of Man;

   i,n,_year: Integer;

   _name: String;

 

begin

   Write('Enter number of man: ');

   ReadLn(n);

   for i := 1 to n do

   With people[i] do

   begin

       WriteLn('Man[',i,']:');

       Write('Enter name: ');

       ReadLn(name);

       Write('Enter surname: ');

       ReadLn(surname);

       Write('Enter birthday Day/Month/Year: ');

       ReadLn(date.day, date.month, date.year);

       WriteLn;

   end;

   Write('Enter year: ');

   ReadLn(_year);

   for i := 1 to n do

   With people[i] do

       if (date.year = _year) then

           WriteLn('Name: ',name,' Surname: ',surname);

   WriteLn;

   Write('Enter name: ');

   ReadLn(_name);

   for i := 1 to n do

   With people[i] do

       if (name = _name) then

       begin

           Write(surname,' ',name);

           WriteLn(' ',date.day,'.',date.month,'.',date.year);

       end;

   ReadLn;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?