В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
curlyprettygirl
curlyprettygirl
26.05.2022 16:14 •  Информатика

Написать программу, решающую : вася имеет х рублей на карманные расходы. сколько банок газировки он сможет купить, если газировка стоит y рублей.

Ответ:
88арина99
88арина99
11.10.2020 03:53

var money, price, count: integer;

begin

 writeln('Введите количество денег и стоимость одной газировки');

 readln(money, price);

 count := 0;

 if(money >= price) then begin repeat

   money := money - price;

   inc(count, 1);

 until money < price;  

 writeln('Петя может купить ', count, ' банок газировки');

 end else writeln('Вася не может купить газировку.');

end.

Объяснение:

1) Создаём переменные

money - количество денег у Васи.

price - цена одной газировки.

count - количество банок после покупки.

2) Запрашиваем сумму денег Васи.

3) Проверяем количество денег, если у Васи денег меньше чем цена одной газировки, то говорим пользователю, что Вася не может купить газировку.

4) Через цикл получаем количество банок и выводим ответ.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?