В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tatsawi
tatsawi
21.02.2023 14:40 •  Информатика

Напишите программу,которая запрашивает год и выдаёт на экран количество дней в этом году (год бывает високосным или нет)

Ответ:
ZнyцPлaй
ZнyцPлaй
11.10.2020 03:39

Объяснение:

#include <iostream>

using namespace std;

int main() {

int year;

cin >> year;

if (year % 4 == 0) {

 if (year % 100 == 0) {

  if (year % 400 == 0) cout << "366 days\n";

  else cout << "365 days\n";

 }

 else cout << "366 days\n";

}

else cout << "365 days\n";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?