В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lerkakotik1983
lerkakotik1983
21.09.2021 05:52 •  Информатика

По c++!

изменение исходного массива

дан двумерный массив из четного числа строк размером n×m. требуется составить программу, которая меняет местами первую строку со второй, третью — с четвертой и т. д.

первая строка содержит два натуральных числа n, m (n,m≤100).

следующие n строк содержат по m чисел, не превосходящих 109 по модулю — элементы массива.

требуется вывести n строк по m чисел в каждой — измененный массив.

входные данные

4 3

1 2 3

4 5 6

7 8 9

9 8 7

выходные данные

4 5 6

1 2 3

9 8 7

7 8 9

Ответ:
pollywhite1
pollywhite1
11.10.2020 03:00

#include <iostream>

int main(){

  int n, m;

  std :: cin >> n >> m;

  int array[109][109];

  for (int i = 0; i<n; ++i){

      for (int j = 0; j<m; ++j)

      {

            if (i==0 || i%2==0) std :: cin >> array[i+1][j];

            else std :: cin >> array[i-1][j];

      }

  }

   for (int i=0; i<n; ++i){

       for (int j= 0; j<m; ++j)

       {

            std :: cout << array[i][j]<< ' ';

       }

       std :: cout << std :: endl;

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?