В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
0680820429
0680820429
18.06.2022 11:10 •  Информатика

получив на вход число x, ниже программа выводит два числа- m и n. var x, m, n: integer;

begin

readln (x);

m: =0; n: =0;

while x> 0 do

begin

if nm: =m+1;

x: =x div 10;

end;

writeln (m); writeln (n)

end.

известно, что при некотором значении х были выведены числа 4 и 8. укажите наибольшее и наименьшее из таких чисел х. сколько всего существует таких х?

Ответ:
juehxbrf
juehxbrf
27.10.2021 15:02
Объяснение:

1)Число точно больше 100, чтобы L было 3.

2)Какие бы числа мы не ставили на позициях единиц и десятков, результата они никакого не дадут, тк отрезаются командой div

3)Ближайшее необходимое число: 500

Дописал программу, чтобы проверить. Она выводит количество подходящих комбинаций при вводе всех чисел от 1 до 500.

var

x, L, M,count,i: integer;

begin

count:=0;

for i:=1 to 500 do

begin

x:=i; L := 0;M := 0;

while x > 0 do

begin

L := L + 1; x := x div 10;

if L mod 2 = 0 then

M := M + (x mod 10);

end;

//write(L,' ');write(M);

if (L=3) and (M=5) then inc(count);

end;

writeln(count);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?