В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Дан массив из 40 элементов. каждый элемент может принимать целочисленные значения от 0 до 200. напишите программу, которая позволит определить, все ли элементы массива различны. программа должна вывести одно из сообщений «есть одинаковые элемены» или «все элементы различны».​

Ответ:
maksimlimanskiy
maksimlimanskiy
11.10.2020 02:09

var a: array [0..39] of integer; i,b: integer;

begin

randomize;

for i:=0 to 39 do a[i]:=random(0,200);

b:=1;

for i:=0 to 39 do begin

if b=39 then begin writeln('Все элементы различны'); break end

else

if (a[i]<>a[b]) and (b<39) then b+=1

else begin writeln('Есть одинаковые элемены'); break end

end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?