В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
света979
света979
22.12.2021 08:22 •  Информатика

Надо написать программу которая по заданному числу n находит два числа- x и y разность квадратов которых равна n

Ответ:
Mia112
Mia112
11.10.2020 01:06

Программа запускалась в PascalABC.NET

var x,y,n: integer;

begin

 writeln(' Введите n');

 readln(n);

 for x:=1 to 100 do

   for y:=1 to 100 do

     if sqr(x)-sqr(y)=n then

       begin

         writeln(x,' ',y);

         exit;

       end;

end.

Объяснение:


Надо написать программу которая по заданному числу n находит два числа- x и y разность квадратов кот
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?