В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
roncray1
roncray1
28.05.2022 18:15 •  Информатика

Напишите программу, которая получает на вход числа а и в, а так же число х. если х =1, то вывести сумму первых двух чисел, если х=2, то разность. программа должна вывести число, а так же словесное описание, какая операция была выбрана.

Ответ:
icrupnov
icrupnov
05.08.2020 13:52

Предоставляю программу на языке Pascal!

var

A, B, X: integer;

begin

readln (A, B, X);

if (X = 1) then write (A+B, ' - сумма')

else if (X = 2) then write (A-B, ' - разность');

end.

0,0(0 оценок)
Ответ:
mashaleonteva2
mashaleonteva2
05.08.2020 13:52

PascalABC.NET

begin

 var (a, b, x) := ReadInteger3;

 if x = 1 then

   Print('Сумма', a + b)

 else if x = 2 then

   Print('Разность', a - b)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?