В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kiss537
Kiss537
25.07.2020 14:21 •  Информатика

Решить 4 в pascal.написать программу с "массив" и "цикл"​.заранее !

Ответ:
n1kitat
n1kitat
11.09.2020 17:15

Объяснение:

program z4;

var x:array[1..5] of real;

   y:array[1..8] of real;

   z,z1,z2:real;

   i:byte;

begin

 for i:=1 to 5 do begin

   read(x[i])

 end;

 for i:=1 to 8 do begin

   read(y[i])

 end;

 z1:=0;

 for i:=1 to 5 do begin

   z1:=z1+x[i]

 end;

 z2:=0;

 for i:=1 to 8 do begin

   z2:=z2+y[i]

 end;

 z:=x[1]/z1-y[5]/z2;

 write('z=',z)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?