В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hakimov676
hakimov676
27.10.2021 05:16 •  Информатика

Написать программу сортировки массива из семи чисел равных индексу по убыванию, написать трассировку программы . паскаль

Ответ:
masha007009
masha007009
06.01.2020 14:03

var a: array[0..9] of integer;

i,k,b,c: integer;

begin

for i: =0 to 9 do

begin

a[i]: =random(100);

writeln(i+1,' число: ',a[i]);

end;

for i: =0 to 9 do

begin

for k: =0 to 9 do

begin

if a[i]

begin

b: =a[i];

c: =a[k];

a[i]: =c;

a[k]: =b;

k: =0;

end;

end;

end;

writeln('числа по возрастанию: ');

for i: =0 to 9 do

writeln(i+1,' число: ',a[i]);

begin

end;

end.

тут немного больше чем надо

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?