В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
новичок618
новичок618
28.01.2022 04:40 •  Информатика

Необходимо написать программу, сортирующую случайный массив следующим метод является модификацией пузырьковой сортировки и состоит из двух этапов - подъема и спуска. при подъеме последовательно сравниваются соседние элементы a[i] и a[i+1] до тех пор, пока не будет сделана первая перестановка. пусть эта перестановка затронула элементы a[k] и a[k+1] . следующим этапом является спуск. новый элемент a[k] сравниваются с a[k−1] и если a[k] < a[k−1] , то выполняется перестановка. сравнение продолжается в нисходящем направлении (т.е. для a[k−1] и a[k−2] , a[k−2] и a[k−3] и т.д.) до тех пор, пока выполняются перестановки либо достигается начало массива.
после этого возобновляется подъем с позиции i = k+1. таким образом,
сортировка состоит из сменяющих друг друга процессов подъема (до
первой перестановки) и спуска (до первого отсутствия перестановки) до тех пор, пока при подъеме не будет затронут последний элемент
массива a[n−1] (при этом спуск также должен быть выполнен).

, , написать именно в соответствии с этим условием, язык: питон / паскаль abc, ну главное здесь - алгоритм нужен понятный. важно: должно быть не более 2 циклов (не условных операторов, а именно циклов), неважно какой длины и каких, но не более двух.

Ответ:
hhwjsbjweujskzks
hhwjsbjweujskzks
10.10.2020 23:41

===== С++ 17 =====

#include <iostream>

using namespace std;

void swap(int &a, int &b)

{

   int t = a;

   a = b;

   b = t;

}

int main()

{

   int n;

   cin >> n;

   int a[n];

   srand(time(NULL));

   for(int i = 0; i < n; i++)

   {

       a[i] = rand() % 198 - 99;

       cout << a[i] << " ";

   }

   cout << endl;

   bool perm = false;

   int j;

   for(int i = 0; i < n - 1; i++)

   {

       if(a[i] > a[i + 1])

       {

           swap(a[i], a[i + 1]);

           j = i;

           perm = true;

           while(perm && (j > 0))

               if(a[j] < a[j - 1])

               {

                   perm = true;

                   swap(a[j], a[j - 1]);

                   j--;

               }

               else perm = false;

       }

   }

   for(int i = 0; i < n; i++)

       cout << a[i] << " ";

   cout << endl;

   return 0;

}


Необходимо написать программу, сортирующую случайный массив следующим метод является модификацией пу
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?