В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hojimutito
hojimutito
30.11.2020 22:27 •  Информатика

Напишите программу, которая определяет, что за атом (или ион) образовался. если количество электронов не равно количеству протонов, то образовался ион. в противном случае — нейтральный атом. название элемента определяется количеством протонов. изотоп — по числу нейтронов. формат ввода вводятся 3 целых числа, обозначающие количество электронов, протонов и нейтронов, образующих атом, каждое с новой строки. формат вывода на первой строке — атом или ион. далее — название элемента (в данном случае только водород или гелий). изотоп (см. таблицу). возможные варианты:

Ответ:
Arsen00628
Arsen00628
10.10.2020 23:33

===== PascalABC.NET =====

begin

 // неверные варианты вызовут ошибку при выполнении

 var mp := Arr('водород', 'гелий');

 var mn := Arr('протий','дейтерий','тритий','гелий-3','гелий-4');

 var (e, p, n) := ReadInteger3;

 Writeln(e = p ? 'атом' : 'ион');

 Writeln(mp[p - 1]);

 Writeln(p = 1 ? mn[n] : mn[n + 2])

end.


Напишите программу, которая определяет, что за атом (или ион) образовался. если количество электроно
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?