В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
abdulaevamesed
abdulaevamesed
09.03.2020 02:23 •  Информатика

Вмассиве состоящим из 30 целых чисел вводят оценки 10 учениов ,нужно вывести на экран оценки в виде таблицы: в первом столбце номер ученика,во втором его оценки.написать программу паскаль

Ответ:
Sergey15211
Sergey15211
24.05.2020 04:07

var a:array[1..2,1..30] of integer;
i,j:integer;
Begin
    for i:= 1 to 30 do begin
        writeln('Введите номер ученика:');
        read(a[1,i]);
        writeln('Введите оценку:');
        read(a[2,i]);
    end;
    
    for i:= 1 to 10 do begin
      writeln(i:2,' - ');
        for j:= 1 to 30
          if a[1,j]=i then
                write(a[2,i],' ');
    end;        
    readkey;
End.   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?