В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dora2020
Dora2020
18.11.2022 02:28 •  Информатика

Написать программу в паскале, которая вычисляет и
выводит на экран в виде таблицы значения функции f (x) на отрезке [-1; 1] с шагом 0.2 .

Ответ:
OWERpass
OWERpass
10.10.2020 22:19

===== PascalABC.NET =====

begin

 var n := Trunc((1 - (-1)) / 0.2);

 for var i := 0 to n do

 begin

   var x := -1 + 0.2 * i;

   Write(x:4:1);

   if x < 0.2 then

     Writeln(3 * (Sqr(x + 8) - 4):16:9)

   else

     Writeln(8 + Sin(x) / x:16:9);

 end

end.


Написать программу в паскале, которая вычисляет и выводит на экран в виде таблицы значения функции f
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?