В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Берегиня
Берегиня
15.08.2021 14:07 •  Информатика

37 ! составить программу на pascal.

условие: даны три стороны треугольника. вычислите площадь и периметр.
ход решения: ввести три цифры - стороны треугольника и с форум нахождения площади и периметра треугольника найти их.

Ответ:
Ксюхахаха
Ксюхахаха
10.10.2020 21:14

var a,b,c,p,s: real;

begin

 write('Введите 1-ю сторону: '); readln(a);

 write('Введите 2-ю сторону: '); readln(b);

 write('Введите 3-ю сторону: '); readln(c);

 p:= a + b + c;

 s:=sqrt((p/2)*(p/2-a)*(p/2-b)*(p/2-c));

 writeln('Периметр = ', p);

 writeln('Площадь = ', s);

end.

0,0(0 оценок)
Ответ:
инна103
инна103
10.10.2020 21:14

===== PascalABC.NET =====

begin

 var (a, b, c) := ReadReal3('Введите длины сторон через пробел:');

 var P := a + b + c;

 var p2 := P / 2;  // полупериметр

 var S := Sqrt(p2 * (p2 - a) * (p2 - b) * (p2 - c)); // ф-ла Герона

 Println('P =', P, '   S =', S)

end.


37 ! составить программу на pascal. условие: даны три стороны треугольника. вычислите площадь и пери
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?