В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Begzodik
Begzodik
11.09.2020 11:51 •  Информатика

Написать программу на языке паскаль которая вызывает из модуля подпрограмму, которая печатает содержимое непустого текстового файла по рядкам, вставляя в начало рядка слово "рядок" и номер этого рядка(4 позиции). ​

Ответ:
Pomogu0pogalycta
Pomogu0pogalycta
23.08.2020 11:20

interface

procedure PrintText(fn: string);

implementation  

procedure PrintText(fn: string);

begin

 var i := 1;

 foreach var s in ReadLines(fn) do

 begin

   Writeln(i:4, ' ', s);

   i += 1

 end;

end;

end.

uses nekrasov;   // вызывающая программа (другой файл)

begin

 var fn := ReadlnString('Укажи имя файла:');

 if FileExists(fn) then

   PrintText(fn)

 else

   Println('Файл не найден')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?