В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
milyukovnikita
milyukovnikita
19.12.2022 11:07 •  Информатика

Составить программу вычисления количества положительных, кратных 5 элементов массива, состоящего из 25 целых чисел

Ответ:
cocscocsovich3
cocscocsovich3
10.10.2020 20:54

var a:array [1..25] of integer;

i,k:integer;

begin

write('Массив ');

for i:=1 to 25 do

begin

a[i]:=random(31)-15;

write(a[i]:5);

if (a[i] mod 5 = 0) and (a[i]>0) then k:=k+1

end;

writeln;

write('Количество положительных, кратных 5, элементов массива равно ',k)

end.

0,0(0 оценок)
Ответ:
AgumiChan
AgumiChan
10.10.2020 20:54

===== PascalABC.NET =====

begin

 var a := ArrRandom(25, -99, 99);

 a.Println;

 a.Count(p -> (p > 0) and (p mod 5 = 0)).Println

end.


Составить программу вычисления количества положительных, кратных 5 элементов массива, состоящего из
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?