В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Дан массив из 8 целых чисел. составить программу вычисления суммы элементов массива меьнших 10

Ответ:
макс240723212321
макс240723212321
11.09.2020 16:25

var a: array[1..8] of integer;

i,s: integer;

begin

randomize;

s:=0;

write('массив: ');

for i:=1 to 8 do begin

a[i]:=random(41)-20;

if a[i]<10 then s:=s+a[i];

write(a[i],' ');

end;

writeln;

write('сумма: ',s);

end.


Дан массив из 8 целых чисел. составить программу вычисления суммы элементов массива меьнших 10
0,0(0 оценок)
Ответ:
weelrockster
weelrockster
11.09.2020 16:25

PascalABC.NET

begin

 var a := ArrRandom(8, -20, 20);

 a.Println;

 a.Where(p -> p < 10).Sum.Println

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?