В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Mellisa11111111
Mellisa11111111
07.10.2022 08:31 •  Информатика

3. дано целое трехзначное число а .составить программу, которая выводит сумму цифр данного числа. например, вводится число 423, а выводится число 9.

Ответ:
ирина1844
ирина1844
10.10.2020 20:17

===== PascalABC.NET =====

begin

 var n := Abs(ReadInteger);

 var s := 0;

 while n > 0 do

 begin

   s += n mod 10;

   n := n div 10

 end;

 Write(s)

end.


3. дано целое трехзначное число а .составить программу, которая выводит сумму цифр данного числа. на
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?