В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
EkaterinaZeyb
EkaterinaZeyb
29.10.2022 06:14 •  Информатика

Написать программу в python, которая создает папку "личные дела", и создает в нем 3 папки "информация", "работы", "разное". в папке личные дела создать файл "инфо.txt" содержащий номер телефона.

Ответ:

import os

def mkdir_creator():

   path = os.getcwd()+'/Личные дела'

   try:

       os.mkdir(path)

       os.mkdir(path+'/Информация')

       os.mkdir(path+'/Работы')

       os.mkdir(path+'/Разное')

       with open(path+'/Инфо.txt', 'w') as f:

           f.write('89990102233')

   except OSError:

       print ("Создать директории не удалось")

   else:

       print ("Успешно созданы директории")

mkdir_creator()

Объяснение:

Python 3.7

tg = Fr0DK

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?