В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Алёнаум1
Алёнаум1
28.11.2021 07:07 •  Информатика

Информатика, !
10 вопрос
нужно написать программу

Ответ:
baller59
baller59
10.10.2020 19:13

var n,s,p,max:integer;

begin

p:=1;

max:=0;

s:=0;

write('Введите число ');

readln(n);

While(n>0) do begin

s:=s+(n mod 10);

p:=p*(n mod 10);

if ((n mod 10) > max) Then max:= n mod 10;

n:=n div 10;

end;

write('сумма всех цифр ',s,' произведение цифр ',p,' маскимальное число ',max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?