В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
glukhovivan2007
glukhovivan2007
16.07.2022 10:18 •  Информатика

напишите программу, которая определяет среднюю температуру за сентябрь. температура задается случайными числами в диапазоне от 5 до 15 градусов

Ответ:
sasha17210
sasha17210
06.08.2020 10:52

#include <iostream>

#include <cstdlib>

#include <math.h>

#include <time.h>

using namespace std;

int main()

{

system("chcp 1251 > null");

srand(time(0));

int n = 30;

int z = 0;

double sum = 0;

double sr = 0;

cout << "Температура: \n";

for(int i = 0; i<n; i++){

   z = rand()%11+5;

   cout << "\n" << z;

   sum = sum + z;

}

sr = sum/n;

cout << "\n\nСредняя температура за сентябрь: " << sr;

}

Оценивать так же можно кнопочкой "Лучший ответ" :З

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?