В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
stecykuliamail
stecykuliamail
21.05.2022 02:51 •  Информатика

Напишите программу на python которая считает сколько цифр окончиваетсч на 2; такуюде но для чисел оканчивающинся на 4 и для чисел оканчивающинся на 7!
так же напишите программу которая считает минимум среди двузначних, либо среди первых 5 чисел! 100 ! ​

Ответ:
УльянаТонких
УльянаТонких
10.10.2020 17:35

1)

print("Введите числа через пробел")

list1 = input().split()

counter = 0

for elem in list1:

   if(elem[-1]=='2'):

       counter += 1

print(counter)

2)

print("Введите числа через пробел")

list1 = input().split()

counter = 0

for elem in list1:

   if(elem[-1]=='4'):

       counter += 1

print(counter)

3)

print("Введите числа через пробел")

list1 = input().split()

counter = 0

for elem in list1:

   if(elem[-1]=='7'):

       counter += 1

print(counter)

4)

list1 = input().split()

counter = 0

list2 = []

key = False

for i in list1:

   if(len(i) >= 2):

       key = True

       list2.append(i)

list1 = [int(i) for i in list1]

if not(key):

   print(min(list1[0:4]))

else:

   print(min(list2))

То же самое в pastebin:

https://pastebin.com/byZKnUaF

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?