В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу на с++!
в данной строке удвоить все цифры и малые латинские буквы.

Ответ:
aruuuukaa12
aruuuukaa12
10.10.2020 17:13

#include <iostream>

#include <string>

using namespace std;

bool isb(char t)

{

bool f=false;

string dic="1234567890";

for(int i=0;i<dic.size();i++)

if(dic[i]==t)

return !f;

return f;

}

int main()

{

string s;

int i=0;

getline(cin,s);

while(i<s.size())

{

if(isb(s[i]))

{

s.insert(i,1,s[i]);

i++;

}

i++;

}

cout<<s<<endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?