В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
okszav
okszav
20.06.2021 10:12 •  Информатика

Написать программу на языке с++(со всеми объяснениями )
написать функцию, которая принимает строку. удаляет из строки символы, не являющиеся символами латинского алфавита. возвращает количество удаленных символов.​

Ответ:
jdkxnVAkx
jdkxnVAkx
10.10.2020 15:58

#include <iostream>

#include <string>

#include <algorithm>

#include <Windows.h>

using namespace std;

bool check_alphabet(char symbol) {

string alphabet = "";

for (size_t j = 0; j < alphabet.size(); j++)

{

 if (alphabet[j] == symbol) {

  return true;

 }

}

return false;

}

pair<int,string> erase_counter_char_in_str_not_latin(string str) {

int i = 0;

int count = 0;

while (i <= str.size() - 1) {

 if (not (check_alphabet(toupper(str[i] {

  str.erase(str.begin() + i);

  count++;

  i--; // раз удалили, то нужно вернуться назад на один: i~45m -> i5~m (i уже идёт на следующий)

 }

 i++;

}

return make_pair(count, str);

}

int main()

{

SetConsoleCP(1251);

SetConsoleOutputCP(1251);

setlocale(LC_ALL, "Russian");

string str;

cout << "Введите строку: " << endl;

cin >> str;

pair<int,string> pair_count_str = erase_counter_char_in_str_not_latin(str);

cout << endl << "Удалено: " << pair_count_str.first << endl;

cout << "Конечная строка: " << pair_count_str.second;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?