В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
shadow909
shadow909
01.10.2021 19:29 •  Информатика

C-free . напишите программу, которая вводит строку и выводит ее, сокращая каждый раз на 1 символ до тех пор, пока в строке не останется 1 символ.

Ответ:
Vip6longin
Vip6longin
05.08.2020 10:53

#include <stdio.h>

#include <conio.h>

using namespace std;

int main()

{

char *Arr = new char[500];

printf("Entered string \n");

gets_s((char*)Arr, 500);

int count = 0;

for (int i = 0; Arr[i] != '\0'; i++)

{

 count++;

}

if (count == 1)

{

 return 0;

}

else

{

 for (int j = count; j>0; j--)

 {

  for (int k = 0; k < j; k++)

  {

   

   printf( "%c", Arr[k]);

  }

  printf("\n");

 }

}

delete[] Arr;

_getch();

return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?