В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zlatasidorowa
zlatasidorowa
02.03.2022 06:22 •  Информатика

Напишите программу на pascalabc для решения : мальчик решил накопить деньги. в первый месяц он отложил a рублей, а каждый следующий месяц он откладывал на d рублей больше, чем в предыдущий. сколько рублей мальчик накопит за n месяцев? ​

Ответ:
TheTanyaStar2k
TheTanyaStar2k
10.10.2020 14:58

Var  a, d, n, i, otv: integer;

begin

  read(a,d,n);                                - ввод всех значений

  otv:=a;                                        - в переменную где будет храниться

  for i:=1 to n do                              ответ записываем начальный взнос

  begin

     a:=a+d;                                     - увеличиваем в цикле взнос

     otv:= otv + (a);                         - добовляем взнос к нашему ответу

  end;

  writeln(otv);                                 - выводим ответ

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?