В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
avramenko0707
avramenko0707
01.07.2020 17:51 •  Информатика

Напишите программу определяющую количество максимальных чисел в массиве. массив состоит из 10 чисел

Ответ:
dianahaliullina1
dianahaliullina1
10.10.2020 14:31

На языке Паскаль:

const

  n = 10;  

var

   i, a, max, count: integer;

begin

max = -32768 ;

count := 0;

writeln('МАссив:');

for i := 1 to n do

   begin

   read(a);

 if a > max  

   then  

       begin

       max := a;

       count := 1;

     end;

   else

   if a = max

   then

       inc(count)

   end;

   writeln('Count max = ', count);

end.

0,0(0 оценок)
Ответ:
ВкусноеМясо
ВкусноеМясо
10.10.2020 14:31

begin

 var a := ArrRandom(10, 1, 9);

 a.Println;

 Println('Кол-во чисел, равных max:',

     a.FindAll(p -> p = a.Max).Count)

end.


Напишите программу определяющую количество максимальных чисел в массиве. массив состоит из 10 чисел
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?