В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mariannabatman
mariannabatman
10.10.2022 15:07 •  Информатика

Составить программу вычисления функции
y=sin(x^2+1.67*pi)
для значений x, принадлежащих диапазону (0-15). результат вывести в виде таблицы

Ответ:
светлана440
светлана440
10.10.2020 14:27

PascalABC.NET

begin

 var n := ReadInteger('Сколько точек будете вводить?');

 for var i := 1 to n do

 begin

   var x := ReadReal;

   Writeln(x:10:5, Sin(Sqr(x) + 1.67 * Pi):20:15)

 end

end.

Чтобы получить вид таблицы, после ввода числа точек нужно в следующей строке вводить весь набор х сразу и через пробел

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?