В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pvale4ka
pvale4ka
20.01.2023 14:13 •  Информатика

Составьте программу которая определяет какое из трёх наибольшее. создать программу на языке си, ​

Ответ:
ASabina1111111
ASabina1111111
10.10.2020 13:26

#define _CRT_SECURE_NO_WARNINGS

#include <iostream>

#include <stdio.h>

int main()

{  

 float a, b, c;

 setlocale(LC_ALL, "Russian");

 printf("Введите три числа: ");

 scanf("%f %f %f", &a, &b, &c);

 if (a > b && a > c)

     printf("Наибольшее число = %f", a);

   else if (b > a && b > c)

     printf("Наибольшее число = %f", b);

   else if (c > a && c > b)

     printf("Наибольшее число = %f", c);

   else

     printf("Наибольшее значение имеют несколько чисел");

}

0,0(0 оценок)
Ответ:
avasjanom
avasjanom
10.10.2020 13:26

#include <stdio.h>

int main()

{

   int a, b, c, max;

   char s;

   scanf("%d%d%d", &a, &b, &c);

   max = a;

   s = '1';

   if (b > max)

   {

       max = b;

       s = '2';

   }

   if (c > max) s = '3';

   printf("%c", s);

   return 0;

}

Выводится номер в порядке ввода наибольшего числа, т.е. 1, 2 или 3.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?