В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
eevelinka742
eevelinka742
30.05.2022 08:50 •  Информатика

Написать программу c++ для решения следующей : упорядочить по возрастанию элементы каждой строки матрицы а(10,8) и вывести ее в виде таблицы.

Ответ:
mobidik77
mobidik77
05.08.2020 10:19

#include <iostream>

#include <iomanip>

using namespace std;

int main()

{

   int m=10, n=8;

   int a[m][n];

   srand(time(0));

   for(int i=0; i<m; i++)

   {

       for(int j=0; j<n; j++)

       {

           a[i][j]=-99+rand()%199;

           cout << setw(4) << a[i][j];

       }

       cout << endl;

   }

   cout << endl;

   // сортировка

   int t;

   for(int i=0; i<m; i++)

   {

       for(int k=n-2; i>=0; i--)

           for(int j=0; j<=k; j++)

               if(a[i][j] > a[i][j+1])

               {

                   t=a[i][j]; a[i][j]=a[i][j+1]; a[i][j+1]=t;

               }

       for(int j=0; j<n; j++)

           cout << setw(4) << a[i][j];

       cout << endl;    

   }

   return 0;

}

Прилагается пример вывода.


Написать программу c++ для решения следующей : упорядочить по возрастанию элементы каждой строки мат
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?