В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
jenja117
jenja117
27.12.2020 20:54 •  Информатика

Написать программу которая рассчитывает 10!
использовать цикл с параметром ( счётчиком) и цикл с предусловием.
большое

Ответ:
Tinochka173
Tinochka173
10.10.2020 12:02

Program fact10;

var

i:byte;

fact:longint;

begin

writeln('Цикл с параметром');

fact:=1;

for i:=2 to 10 do

fact:=fact*i;

writeln('10! = ',fact);

writeln('Цикл с предусловием');

fact:=1;

while (i<>1) do

begin

fact:=fact*i;

i:=i-1;

end;

writeln('10! = ',fact);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?