В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ale2005171112
ale2005171112
05.09.2022 17:04 •  Информатика

Даны действительное число х не равное нулю и число n целое. составить программу и вычислить сумму ряда s​

Ответ:
vika2084
vika2084
10.10.2020 11:30

var

 i, n: integer;

 x, s, a, xn: real;

 

begin

 read(n, x);

 a := 1;

 s := 1;

 xn := 1;

 for i := 1 to n do

 begin

   a := a * (2 * i - 1) / sqr (2 * i);

   xn := xn * x;

   s := s - a * xn;

 end;

 write(s * Pi / 2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?