В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
95Laura95
95Laura95
10.10.2021 20:26 •  Информатика

Си ++, , , нужно написать программу с оператором while, которая будет включать пользовательскую функцию для вычисления значения z

Ответ:
Мегамозг0511
Мегамозг0511
10.10.2020 11:28

Исходник ниже.

Объяснение:

#include <iostream>

#include <cmath>

using namespace std;

int main(){

   //"\t" - табуляция

   //fixed - для вывода фиксированного количества знаков после запятой у вещественного числа

   cout << "x\t\ty\t\ta\t\tb\t\tz" << endl;

   double x = 0.5;

   while(x <= 1.9){

       double y = 0.1;

       while(y <= 0.2){

           double a = cos(x*x*x - sqrt(y));

           double b = pow(x * y * y, 1.0 / 3);

           double z;

           if (a > b){

               z = a;

           }

           else{

               z = b;

           }

           cout << fixed << x << "\t" << y << "\t" << a << "\t" << b << "\t" << z << endl;

           y += 0.05;

       }

       x += 1.1;

   }

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?