В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ааааааа59
ааааааа59
07.10.2022 19:24 •  Информатика

Рассмотрим линейный массив целых чисел k [1..50]. напишите программу на языке pascal, используя процедуру, которая отображает положительные элементы на экране.

Ответ:
Qwerty555777999
Qwerty555777999
10.10.2020 10:51

const

 k = 10;

type

 tK = array[1..k] of integer;

var

 i: byte;

 a: tK;

procedure PrintPos(a: tK);

var

 i: byte;

begin

 for i := 1 to k do

   if a[i] > 0 then write(a[i], ' ');

 writeln;

end;

begin

 for i := 1 to k do

   Read(a[i]);

 PrintPos(a);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?