В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
04812
04812
17.12.2020 14:49 •  Информатика

Написать программу , которая в последовательности n-чисел, вычисляет сумму нечётных.​ , нужно. (паскаль)

Ответ:
aselduishenova
aselduishenova
10.10.2020 10:01

program test;

var a:array[1..10000000]of integer;

   i,s,n:integer;

begin

writeln ('Сколько чисел в последовательности?');

read(n);

writeln('Сформированная последовательность:');

for i:=1 to n do begin

a[i]:=random(500);

write (a[i]:4);

end;

writeln;

for i:=1 to n do

if i mod 2=0 then s:=s+a[i];

write ('Сумма четных= ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?