В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
silwana2002
silwana2002
12.05.2020 18:43 •  Информатика

Дано два натуральных числа а и в. напишите программу, которая находит цифру, на которую заканчивается число а в степени b (ab).

Ответ:
platonnikitos
platonnikitos
05.08.2020 09:21
C++

#include <cmath>

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL,"RUS");

  unsigned long a,b;

   cout<<"Введите число а"<<endl;

   cin>>a;

   cout<<"Введите число b"<<endl;

   cin>>b;

   cout<<((unsigned long)pow(a,b))%10;

   system("pause");

   return 0;

}

C#

using System;

class Power {

 static int Main() {

   ulong a, b;

   Console.WriteLine("Введите число а");

   a=Convert.ToUInt64(Console.ReadLine());

   Console.WriteLine("Введите число b");

   b=Convert.ToUInt64(Console.ReadLine());

   Console.WriteLine(Math.Pow(a,b)%10);

   Console.ReadKey();

   return 0;

 }

}

Pascal

program Power;

uses crt;

var

a,b,c:Int64;

i:byte;

begin

 writeln ('Введите число a');

 readln(a);

 writeln ('Введите число b');

 readln(b);

 

 c:=1;

 for i:=1 to b do

 c:=c*a;

 

 writeln (c mod 10);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?