В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kakady0071
Kakady0071
10.02.2023 20:43 •  Информатика

Используя цикл с параметром, написать программу, которая вычисляет сумму заданного с клавиатуры числа элементов ряда 1/2+1/4-1/6+1/

Ответ:
ninadyukovap0a6fu
ninadyukovap0a6fu
10.10.2020 09:15

program Calc;

var

 i, n, m: Integer;

 s: Double;

begin

 Write ('Количество членов ряда = ');

 ReadLn (m);

 s := 0.5;

 n := 1;

 for i := 2 to m do begin

   s := s + n / (i * 2);

   n := -n;

 end;

 WriteLn ('S = ', s :20 :20);

 ReadLn;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?