В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
LopsterId1236543
LopsterId1236543
08.01.2021 13:13 •  Информатика

Составьте программу (паскаль) для решения :

в игре " лото" из мешка случайным образом выбираются бочонки , на каждом из которых написано число от 1 до 50. напишите программу, которая выводит наугад первые 3 выигрышных номера.

Ответ:
amira061
amira061
10.10.2020 08:21

program Loto;

var

 L: array [1..50] of Integer;

 a: array [1..3] of Integer;

 i, j, n: Integer;

 b: Boolean;

begin

 for i := Low (L) to High (L) do

   L [i] := i;

 Randomize;

 for i := 1 to 3 do begin

   repeat

     n := Random (51) + 1;

   until L[n] <> 0;

   a [i] := L [n];

   L [n] := 0;

 end;

 for i := 1 to 3 do

   Write (a [i], ' ');

 ReadLn;

end

Объяснение:

сделана проверка чтобы 3 числа не совпадали друг с другом

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?