В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hanbek81
hanbek81
10.09.2020 23:45 •  Информатика

Необходимо написать программу, которая находит минимальный элемент матрицы и ставит его на место первого элемента матрицы(то есть в левый верхний угол)

Ответ:
tttttrrr
tttttrrr
10.10.2020 07:22

const N=5;

var a:array [1..N,1..N] of integer;

i,j,min:integer;

begin

 randomize;

 for i:=1 to N do  

   begin

     for j:=1 to N do

       begin

         a[i,j]:=random(21)-10;

         write(a[i,j]:4);

       end;

     writeln;

   end;

   writeln;

 min:=a[1,1];

 for i:=1 to N do

   for j:=1 to N do

     if a[i,j]<min then

       min:=a[i,j];

 if min<>a[1,1] then a[1,1]:=min;

 for i:=1 to N do

   begin

     for j:=1 to N do

       write(a[i,j]:4);

     writeln;

   end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?