В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dangoreh
dangoreh
03.05.2020 02:19 •  Информатика

Написать программу для pascal по этой

Ответ:
санёк55665464654
санёк55665464654
11.09.2020 10:29

program ExampleN;

uses ...;  // здесь укажите где в вашей версии Паскаля

var

 x, y, z, r, s: Real;

begin

 Write ('Введете x, y: ');

 ReadLn (x, y);

 z := Sqr (Cos (x));

 if z = 0.0 then

   r := 0.0

 else if z > 0.0 then

   r := Exp (Ln (z) / 3)

 else

   r := - Exp (Ln (-z) / 3);

 s := 8 * r - y;

  WriteLn (s);

 ReadLn;

end.

Объяснение:

в паскале нет стандартной функции извлечения корня, поэтому приходится использовать такой алгоритм:

 if z = 0.0 then

   r := 0.0

 else if z > 0.0 then

   r := Exp (Ln (z) / 3)

 else

   r := - Exp (Ln (-z) / 3);

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?